summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-jupyter')
-rw-r--r--dev-python/pytest-jupyter/Manifest1
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.9.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-jupyter/Manifest b/dev-python/pytest-jupyter/Manifest
index 1d696d8c8ceb..136f4b06cd30 100644
--- a/dev-python/pytest-jupyter/Manifest
+++ b/dev-python/pytest-jupyter/Manifest
@@ -1 +1,2 @@
DIST pytest_jupyter-0.8.0.tar.gz 15716 BLAKE2B 9000be141466553346737596e80c5208aa9c1bdd9a72c8b1ae9fa1b8d994dc33f6e237a2eb16e60fa9c1a9040e6711ac45b0420aa865b6c27c48455cc1a11c34 SHA512 7789d4e92a1da254c8ef161a58b63fc494e4b59ce7721d5c501fdce0975452ed53700292e1554c247f5fa58cbe1f87489403f0f5ae97c5260cc3d7c9fc1c3418
+DIST pytest_jupyter-0.9.0.tar.gz 15520 BLAKE2B 59c80b3fc3a6a48c071a3fbf4068b5a3bbef888677f89db5f9e9a573a7de2ad34658a4543978bc747488fdc5f3720104af00fb2878b360bd503d01e851a5b65e SHA512 46e223754f5c36df7783207e8d9589d6c5525adf22b2c476fb7017d5cfac50d9ecdeadf4a7fcfb58e418ba84ee1f966d2655100e5b1c65ed780d34a02580fb7e
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.9.0.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.9.0.ebuild
new file mode 100644
index 000000000000..ac7134dabd4e
--- /dev/null
+++ b/dev-python/pytest-jupyter/pytest-jupyter-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/pytest-jupyter/
+ https://pypi.org/project/pytest-jupyter/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.7[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest