summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-localserver/pytest-localserver-0.3.5.ebuild')
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.3.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.3.5.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.3.5.ebuild
new file mode 100644
index 000000000000..0dceaa510d17
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.3.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Py.test plugin to test server connections locally"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-localserver"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die
+}