summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-markdown/pytest-markdown-1.0.2-r1.ebuild')
-rw-r--r--dev-python/pytest-markdown/pytest-markdown-1.0.2-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pytest-markdown/pytest-markdown-1.0.2-r1.ebuild b/dev-python/pytest-markdown/pytest-markdown-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..9fbad96e498e
--- /dev/null
+++ b/dev-python/pytest-markdown/pytest-markdown-1.0.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517="poetry"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Run tests in your markdown"
+HOMEPAGE="
+ https://github.com/Jc2k/pytest-markdown/
+ https://pypi.org/project/pytest-markdown/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~riscv"
+
+RDEPEND=">=dev-python/commonmark-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]"