summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-order')
-rw-r--r--dev-python/pytest-order/Manifest1
-rw-r--r--dev-python/pytest-order/pytest-order-1.1.0.ebuild40
2 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pytest-order/Manifest b/dev-python/pytest-order/Manifest
index 7f3fa8d69e4a..07ad700037d5 100644
--- a/dev-python/pytest-order/Manifest
+++ b/dev-python/pytest-order/Manifest
@@ -1,2 +1 @@
-DIST pytest-order-1.1.0.tar.gz 43385 BLAKE2B e0bb40d89dbbb382dec2828d024b9a9a8353c87a89d0d9fce517df2be248dc3d9f24672a91f6a9dd82e473d41fb677cc13ef1201563e25402288d5144a8742c0 SHA512 0ce0e0b0437031e672acb838f9e2bb40c2ee8afcc8463c779959309ace125b3a4c92efcf5e156c97037fa6b8d51c255e7cf272427e44587608c2a370289dd3c3
DIST pytest-order-1.2.0.tar.gz 44307 BLAKE2B 82611b713c9ae064c41e966d503c649c130d5a1df520594f513e9ab3d1cf6890fba65afa860822aedcee1a95617d3cd9010f5189d158cd76b2a4b9d25dd7d916 SHA512 f615dd57546e90c614af35fd79e7e579d48a5e709af3324f476d347e191606b81698bde619a2d0c7181e6f3b1a3c41121c1b06b5de87e66ac2caa77b5ea11ad9
diff --git a/dev-python/pytest-order/pytest-order-1.1.0.ebuild b/dev-python/pytest-order/pytest-order-1.1.0.ebuild
deleted file mode 100644
index cefd5410a82e..000000000000
--- a/dev-python/pytest-order/pytest-order-1.1.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="pytest plugin to run your tests in a specific order"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-order
- https://pypi.org/project/pytest-order/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND=">=dev-python/pytest-6.4.2[${PYTHON_USEDEP}]"
-
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_DESELECT=(
- # Appears to fail due to extra warning in pytest 7
- "tests/test_dependency.py::test_order_dependencies_no_auto_mark"
- "tests/test_dependency.py::test_order_dependencies_auto_mark"
- "tests/test_order_group_scope_dep.py::test_class_group_scope_module_scope"
- "tests/test_order_group_scope_named_dep.py::test_class_group_scope_module_scope"
- "tests/test_xdist_handling.py::test_xdist_ordering"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source