summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-repeat/pytest-repeat-0.9.3.ebuild')
-rw-r--r--dev-python/pytest-repeat/pytest-repeat-0.9.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-repeat/pytest-repeat-0.9.3.ebuild b/dev-python/pytest-repeat/pytest-repeat-0.9.3.ebuild
new file mode 100644
index 000000000000..6a9a1c6287c3
--- /dev/null
+++ b/dev-python/pytest-repeat/pytest-repeat-0.9.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin for repeating tests"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-repeat/
+ https://pypi.org/project/pytest-repeat/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_repeat
+ epytest
+}