summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild
index bacf8d476eb3..0962c178654c 100644
--- a/dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit distutils-r1
@@ -14,13 +15,5 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MPL-2.0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pytest-4.4[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
- )"
distutils_enable_tests pytest