summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-runner/pytest-runner-4.2.ebuild')
-rw-r--r--dev-python/pytest-runner/pytest-runner-4.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pytest-runner/pytest-runner-4.2.ebuild b/dev-python/pytest-runner/pytest-runner-4.2.ebuild
deleted file mode 100644
index d3062452b42a..000000000000
--- a/dev-python/pytest-runner/pytest-runner-4.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Adds support for tests during installation of setup.py files"
-HOMEPAGE="https://pypi.org/project/pytest-runner/ https://github.com/pytest-dev/pytest-runner"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- doc? (
- dev-python/jaraco-packaging[${PYTHON_USEDEP}]
- dev-python/rst-linker[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? ( ${RDEPEND} )
-"
-
-# Tests require network access to download packages
-RESTRICT="test"
-
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx
- HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- fi
-}
-
-python_test() {
- esetup.py pytest
-}