summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild')
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild
deleted file mode 100644
index b4eecc6c24f3..000000000000
--- a/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A goodie-bag of unix shell and environment tools for py.test"
-HOMEPAGE="https://github.com/man-group/pytest-plugins https://pypi.org/project/pytest-shutil/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/execnet[${PYTHON_USEDEP}]
- dev-python/contextlib2[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools-git[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )
-"
-RESTRICT="!test? ( test )"
-
-python_test() {
- # various pickling errors, but code works to run pytest-virtualenv tests
- [[ ${EPYTHON} == pypy ]] && return
-
- esetup.py test
-}