summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild')
-rw-r--r--dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild b/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild
new file mode 100644
index 000000000000..aa804018536a
--- /dev/null
+++ b/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin to support for a predictable and repeatable temporary directory"
+HOMEPAGE="https://github.com/saltstack/pytest-tempdir"
+SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}