summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest/files/pytest-4.5.0-strip-setuptools_scm.patch')
-rw-r--r--dev-python/pytest/files/pytest-4.5.0-strip-setuptools_scm.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pytest/files/pytest-4.5.0-strip-setuptools_scm.patch b/dev-python/pytest/files/pytest-4.5.0-strip-setuptools_scm.patch
new file mode 100644
index 000000000000..ae6be933bca6
--- /dev/null
+++ b/dev-python/pytest/files/pytest-4.5.0-strip-setuptools_scm.patch
@@ -0,0 +1,25 @@
+diff --git a/setup.py b/setup.py
+index 0fb5a58a..302b5dda 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,4 +1,5 @@
+ from setuptools import setup
++import os
+
+ # TODO: if py gets upgrade to >=1.6,
+ # remove _width_of_current_line in terminal.py
+@@ -18,10 +19,12 @@ INSTALL_REQUIRES = [
+ ]
+
+
++with open("src/_pytest/_version.py", 'wt') as fp:
++ fp.write('version = "{}"'.format(os.environ['PV']))
++
+ def main():
+ setup(
+- use_scm_version={"write_to": "src/_pytest/_version.py"},
+- setup_requires=["setuptools-scm", "setuptools>=40.0"],
++ version=os.environ['PV'],
+ package_dir={"": "src"},
+ # fmt: off
+ extras_require={