summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-docs/python-docs-3.5.2.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.5.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-3.5.2.ebuild b/dev-python/python-docs/python-docs-3.5.2.ebuild
new file mode 100644
index 000000000000..994eca485ab2
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="mirror://gentoo/python-${PV}-docs-html.tar.bz2"
+# The upstream digest is unstable, see https://bugs.python.org/issue25170
+#SRC_URI="https://docs.python.org/${PV%.*}/archives/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="3.5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ dohtml -A xml -A inv -r ./
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}