summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-dotenv/python-dotenv-0.19.2-r1.ebuild')
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.19.2-r1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/python-dotenv/python-dotenv-0.19.2-r1.ebuild b/dev-python/python-dotenv/python-dotenv-0.19.2-r1.ebuild
deleted file mode 100644
index 066098d96dfe..000000000000
--- a/dev-python/python-dotenv/python-dotenv-0.19.2-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Manage .env files"
-HOMEPAGE="https://github.com/theskumar/python-dotenv"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86"
-
-DEPEND="
- test? (
- >=dev-python/click-5[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/sh-1.09[${PYTHON_USEDEP}]
- )"
-
-DOCS=( CHANGELOG.md README.md )
-
-PATCHES=(
- # rename the entry point (note: old name is needed in tests)
- # https://bugs.gentoo.org/798648
- # also fix syntax since it doesn't seem to work anymore
- # https://bugs.gentoo.org/833389
- "${FILESDIR}"/python-dotenv-0.19.2-entry-points.patch
-)
-
-distutils_enable_tests --install pytest
-
-src_install() {
- distutils-r1_src_install
-
- # Avoid collision with dev-ruby/dotenv (bug #798648)
- rm "${D}"/usr/bin/dotenv || die
-}