summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-dotenv')
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.14.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
index f73be0464463..facf646f4b77 100644
--- a/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
+++ b/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
@@ -27,3 +27,10 @@ DEPEND="test? (
DOCS=( CHANGELOG.md README.md )
distutils_enable_tests pytest
+
+python_test() {
+ # Tests call the "dotenv" command which needs to be in PATH
+ # https://bugs.gentoo.org/743784
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}