summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-jwt/python-jwt-1.2.0.ebuild')
-rw-r--r--dev-python/python-jwt/python-jwt-1.2.0.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/python-jwt/python-jwt-1.2.0.ebuild b/dev-python/python-jwt/python-jwt-1.2.0.ebuild
deleted file mode 100644
index 1db1e4d42d1f..000000000000
--- a/dev-python/python-jwt/python-jwt-1.2.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="JSON Web Token library for python 3"
-HOMEPAGE="https://github.com/GehirnInc/python-jwt"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hvac/hvac.git"
-else
- SRC_URI="https://github.com/GehirnInc/python-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-BDEPEND="test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- !dev-python/pyjwt
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -e 's/^addopts =.*/addopts = jwt/' setup.cfg || die
- distutils-r1_python_prepare_all
-}