summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-lsp-server/files/python-lsp-server-1.6.0-unpin-all-the-deps.patch')
-rw-r--r--dev-python/python-lsp-server/files/python-lsp-server-1.6.0-unpin-all-the-deps.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/python-lsp-server/files/python-lsp-server-1.6.0-unpin-all-the-deps.patch b/dev-python/python-lsp-server/files/python-lsp-server-1.6.0-unpin-all-the-deps.patch
new file mode 100644
index 000000000000..28bc0f84c6a8
--- /dev/null
+++ b/dev-python/python-lsp-server/files/python-lsp-server-1.6.0-unpin-all-the-deps.patch
@@ -0,0 +1,51 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 8cce90e..18cf2db 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -13,7 +13,7 @@ readme = "README.md"
+ license = {text = "MIT"}
+ requires-python = ">=3.7"
+ dependencies = [
+- "jedi>=0.17.2,<0.19.0",
++ "jedi>=0.17.2",
+ "python-lsp-jsonrpc>=1.0.0",
+ "pluggy>=1.0.0",
+ "docstring-to-markdown",
+@@ -27,26 +27,26 @@ Homepage = "https://github.com/python-lsp/python-lsp-server"
+
+ [project.optional-dependencies]
+ all = [
+- "autopep8>=1.6.0,<1.7.0",
+- "flake8>=5.0.0,<5.1.0",
+- "mccabe>=0.7.0,<0.8.0",
+- "pycodestyle>=2.9.0,<2.10.0",
++ "autopep8>=1.6.0",
++ "flake8>=5.0.0",
++ "mccabe>=0.7.0",
++ "pycodestyle>=2.9.0",
+ "pydocstyle>=2.0.0",
+- "pyflakes>=2.5.0,<2.6.0",
++ "pyflakes>=2.5.0",
+ "pylint>=2.5.0",
+ "rope>=0.10.5",
+ "yapf",
+ "whatthepatch"
+ ]
+-autopep8 = ["autopep8>=1.6.0,<1.7.0"]
+-flake8 = ["flake8>=5.0.0,<5.1.0"]
+-mccabe = ["mccabe>=0.7.0,<0.8.0"]
+-pycodestyle = ["pycodestyle>=2.9.0,<2.10.0"]
++autopep8 = ["autopep8>=1.6.0"]
++flake8 = ["flake8>=5.0.0"]
++mccabe = ["mccabe>=0.7.0"]
++pycodestyle = ["pycodestyle>=2.9.0"]
+ pydocstyle = ["pydocstyle>=2.0.0"]
+-pyflakes = ["pyflakes>=2.5.0,<2.6.0"]
++pyflakes = ["pyflakes>=2.5.0"]
+ pylint = ["pylint>=2.5.0"]
+ rope = ["rope>0.10.5"]
+-yapf = ["yapf", "whatthepatch>=1.0.2,<2.0.0"]
++yapf = ["yapf", "whatthepatch>=1.0.2"]
+ websockets = ["websockets>=10.3"]
+ test = [
+ "pylint>=2.5.0",