summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-lsp-server/files/python-lsp-server-1.7.1-unpin-all-the-deps.patch')
-rw-r--r--dev-python/python-lsp-server/files/python-lsp-server-1.7.1-unpin-all-the-deps.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/python-lsp-server/files/python-lsp-server-1.7.1-unpin-all-the-deps.patch b/dev-python/python-lsp-server/files/python-lsp-server-1.7.1-unpin-all-the-deps.patch
new file mode 100644
index 000000000000..4a8104130e06
--- /dev/null
+++ b/dev-python/python-lsp-server/files/python-lsp-server-1.7.1-unpin-all-the-deps.patch
@@ -0,0 +1,60 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 8d38434..50e8e16 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -13,7 +13,7 @@ readme = "README.md"
+ license = {text = "MIT"}
+ requires-python = ">=3.7"
+ dependencies = [
+- "jedi>=0.17.2,<0.19.0",
++ "jedi>=0.17.2",
+ "python-lsp-jsonrpc>=1.0.0",
+ "pluggy>=1.0.0",
+ "docstring-to-markdown",
+@@ -27,29 +27,29 @@ Homepage = "https://github.com/python-lsp/python-lsp-server"
+
+ [project.optional-dependencies]
+ all = [
+- "autopep8>=1.6.0,<1.7.0",
+- "flake8>=5.0.0,<7",
+- "mccabe>=0.7.0,<0.8.0",
+- "pycodestyle>=2.9.0,<2.11.0",
+- "pydocstyle>=6.2.0,<6.3.0",
+- "pyflakes>=2.5.0,<3.1.0",
+- "pylint>=2.5.0,<3",
++ "autopep8>=1.6.0",
++ "flake8>=5.0.0",
++ "mccabe>=0.7.0",
++ "pycodestyle>=2.9.0",
++ "pydocstyle>=6.2.0",
++ "pyflakes>=2.5.0",
++ "pylint>=2.5.0",
+ "rope>1.2.0",
+ "yapf",
+- "whatthepatch>=1.0.2,<2.0.0"
++ "whatthepatch>=1.0.2"
+ ]
+-autopep8 = ["autopep8>=1.6.0,<1.7.0"]
+-flake8 = ["flake8>=5.0.0,<7"]
+-mccabe = ["mccabe>=0.7.0,<0.8.0"]
+-pycodestyle = ["pycodestyle>=2.9.0,<2.11.0"]
+-pydocstyle = ["pydocstyle>=6.2.0,<6.3.0"]
+-pyflakes = ["pyflakes>=2.5.0,<3.1.0"]
+-pylint = ["pylint>=2.5.0,<3"]
++autopep8 = ["autopep8>=1.6.0"]
++flake8 = ["flake8>=5.0.0"]
++mccabe = ["mccabe>=0.7.0"]
++pycodestyle = ["pycodestyle>=2.9.0"]
++pydocstyle = ["pydocstyle>=6.2.0"]
++pyflakes = ["pyflakes>=2.5.0"]
++pylint = ["pylint>=2.5.0"]
+ rope = ["rope>1.2.0"]
+-yapf = ["yapf", "whatthepatch>=1.0.2,<2.0.0"]
++yapf = ["yapf", "whatthepatch>=1.0.2"]
+ websockets = ["websockets>=10.3"]
+ test = [
+- "pylint>=2.5.0,<3",
++ "pylint>=2.5.0",
+ "pytest",
+ "pytest-cov",
+ "coverage",