summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-lzo/python-lzo-1.14-r1.ebuild')
-rw-r--r--dev-python/python-lzo/python-lzo-1.14-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/python-lzo/python-lzo-1.14-r1.ebuild b/dev-python/python-lzo/python-lzo-1.14-r1.ebuild
index 6493182b8432..6131a4803068 100644
--- a/dev-python/python-lzo/python-lzo-1.14-r1.ebuild
+++ b/dev-python/python-lzo/python-lzo-1.14-r1.ebuild
@@ -19,9 +19,13 @@ KEYWORDS="amd64 ~riscv x86 ~amd64-linux ~x86-linux"
RDEPEND="dev-libs/lzo:2"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest.patch
+)
+
# We can't use pytest at the moment because the package uses "yield tests"
# https://docs.pytest.org/en/6.2.x/deprecations.html#yield-tests
-distutils_enable_tests nose
+distutils_enable_tests pytest
python_prepare_all() {
hprefixify setup.py