summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-mpd2')
-rw-r--r--dev-python/python-mpd2/Manifest1
-rw-r--r--dev-python/python-mpd2/python-mpd2-3.1.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/python-mpd2/Manifest b/dev-python/python-mpd2/Manifest
index 7ce8f8171a44..2ceacdfee098 100644
--- a/dev-python/python-mpd2/Manifest
+++ b/dev-python/python-mpd2/Manifest
@@ -1 +1,2 @@
DIST python-mpd2-3.0.5.gh.tar.gz 67224 BLAKE2B a0c78e3a2624247a7ed4228725dcc09457804636b01b09006bcd61800deefac8887fc9f76b9d7bb21c973e2dd9558e934f3864b2f8f5c041a94633a29f9a781e SHA512 521345b905113eaa56e6ec983e4d968d77dca30f839ab52a00e146f311269828ed383bce460ba1daf61b7f98c63ae3b7a3cbcb55cf917b1c5a5a11cf62b6a7d5
+DIST python-mpd2-3.1.0.gh.tar.gz 69162 BLAKE2B fb9b13f3e73b654d7e2a6ee84907f84ebf354d8f56ee47f58046a28aef1d43b5ddd52bf51f42a3e56dd6d8036010abc74d5537cfe8cf4f976b0a758506879dfe SHA512 9d8dd774540d9e09804fd293ce362401b2253f8021c1581c0764bac0b61d2e4b5f50bb752e5d774459194a717354f28ad5d96d48f29ef0f54011969ec91ff106
diff --git a/dev-python/python-mpd2/python-mpd2-3.1.0.ebuild b/dev-python/python-mpd2/python-mpd2-3.1.0.ebuild
new file mode 100644
index 000000000000..a3d2930f7379
--- /dev/null
+++ b/dev-python/python-mpd2/python-mpd2-3.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="
+ https://github.com/Mic92/python-mpd2/
+ https://pypi.org/project/python-mpd2/
+"
+# as of 3.1.0, sdist is missing some doc files
+SRC_URI="
+ https://github.com/Mic92/python-mpd2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="examples +twisted"
+
+RDEPEND="
+ twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst doc/{changes.rst,commands_header.txt} doc/topics/. )
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ epytest mpd/tests.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples/.
+}