summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/Manifest1
-rw-r--r--dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch30
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild36
3 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/python-ptrace/Manifest b/dev-python/python-ptrace/Manifest
index eb489a031728..68a8a7fa09ec 100644
--- a/dev-python/python-ptrace/Manifest
+++ b/dev-python/python-ptrace/Manifest
@@ -1,2 +1 @@
-DIST python-ptrace-0.9.8.gh.tar.gz 104079 BLAKE2B 3d387beca9c92c0e3bbd5cf2c9d2af447c233b631e894ce1af2cdc697a1a48e24a299bbc998cd187ac9ad0f45bfc886f476afdb69329d761e8730a047731126b SHA512 f50ba7d457bf20a161a99913a552f2e829e97975d7cfbf8cf5d89b4f2320772b537678f2e70b9aaa88341c4f01d4bf41f62683e913628db503152f3510a013a3
DIST python-ptrace-0.9.9.gh.tar.gz 106526 BLAKE2B ff9b85e17fd8d767c3fd1db13f1c69ad0b4e7d47379d6ee9468d9424702d34d7a7a7489590987213707829ab62e5eb83df277d3b60de6d2ad05ac99b93586ca3 SHA512 5f2291a4ca642ab99c49e853f12a3cd4ee911df45326fe077ef5df82b813b54a4351c3c23a195b65342af37aed8ecbc26968f65ce9b6a974863bee0ffd556039
diff --git a/dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch b/dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch
deleted file mode 100644
index fc7e55f6160e..000000000000
--- a/dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Upstream: https://github.com/vstinner/python-ptrace/pull/81
-commit 80e0c97a84eccb8b82737cf40b9c5581c20c245f
-Author: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
-Date: Sat Sep 16 13:49:43 2023 +0200
-
- Remove deprecated `imp` module
-
---- a/setup.py
-+++ b/setup.py
-@@ -28,7 +28,7 @@
- # - git commit -a -m "post-release"
- # - git push
-
--from imp import load_source
-+import importlib.util
- from os import path
- try:
- # setuptools supports bdist_wheel
-@@ -55,7 +55,10 @@ CLASSIFIERS = [
- with open('README.rst') as fp:
- LONG_DESCRIPTION = fp.read()
-
--ptrace = load_source("version", path.join("ptrace", "version.py"))
-+ptrace_spec = importlib.util.spec_from_file_location("version", path.join("ptrace", "version.py"))
-+ptrace = importlib.util.module_from_spec(ptrace_spec)
-+ptrace_spec.loader.exec_module(ptrace)
-+
- PACKAGES = {}
- for name in MODULES:
- PACKAGES[name] = name.replace(".", "/")
diff --git a/dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild b/dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild
deleted file mode 100644
index 53464d743d9b..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python binding of ptrace library"
-HOMEPAGE="https://github.com/vstinner/python-ptrace"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vstinner/python-ptrace"
-else
- SRC_URI="https://github.com/vstinner/python-ptrace/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/six[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/${P}-python3_12.patch"
-)
-
-distutils_enable_tests pytest
-
-src_test() {
- ./runtests.py --tests tests/ || die
-}