summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-slugify/python-slugify-6.1.1.ebuild')
-rw-r--r--dev-python/python-slugify/python-slugify-6.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-slugify/python-slugify-6.1.1.ebuild b/dev-python/python-slugify/python-slugify-6.1.1.ebuild
new file mode 100644
index 000000000000..e06ea5dfd456
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-6.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="dev-python/text-unidecode[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest