summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-socks/python-socks-2.0.1.ebuild')
-rw-r--r--dev-python/python-socks/python-socks-2.0.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-socks/python-socks-2.0.1.ebuild b/dev-python/python-socks/python-socks-2.0.1.ebuild
new file mode 100644
index 000000000000..94d2cb6ce6da
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest