summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-varlink/python-varlink-29.0.2.ebuild')
-rw-r--r--dev-python/python-varlink/python-varlink-29.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-varlink/python-varlink-29.0.2.ebuild b/dev-python/python-varlink/python-varlink-29.0.2.ebuild
new file mode 100644
index 000000000000..1aa35e6e32b0
--- /dev/null
+++ b/dev-python/python-varlink/python-varlink-29.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Varlink protocol"
+HOMEPAGE="https://github.com/varlink/python"
+SRC_URI="https://github.com/varlink/python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+RESTRICT="test"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/python-${PV}"
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}