summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pythonfinder/pythonfinder-2.1.0.ebuild')
-rw-r--r--dev-python/pythonfinder/pythonfinder-2.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pythonfinder/pythonfinder-2.1.0.ebuild b/dev-python/pythonfinder/pythonfinder-2.1.0.ebuild
new file mode 100644
index 000000000000..f68a9f5ef322
--- /dev/null
+++ b/dev-python/pythonfinder/pythonfinder-2.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PythonFinder: Cross Platform Search Tool for Finding Pythons"
+HOMEPAGE="
+ https://github.com/sarugaku/pythonfinder/
+ https://pypi.org/project/pythonfinder/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}