summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytools/pytools-2020.4.4.ebuild')
-rw-r--r--dev-python/pytools/pytools-2020.4.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytools/pytools-2020.4.4.ebuild b/dev-python/pytools/pytools-2020.4.4.ebuild
new file mode 100644
index 000000000000..80c91e37779b
--- /dev/null
+++ b/dev-python/pytools/pytools-2020.4.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE='sqlite'
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="https://mathema.tician.de/software/pytools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest