summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytz')
-rw-r--r--dev-python/pytz/Manifest1
-rw-r--r--dev-python/pytz/files/2018.4-zoneinfo.patch12
-rw-r--r--dev-python/pytz/files/pytz-2018.4-zoneinfo-noinstall.patch18
-rw-r--r--dev-python/pytz/pytz-2018.4.ebuild35
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
index 226e4e893f4e..987f37053d5a 100644
--- a/dev-python/pytz/Manifest
+++ b/dev-python/pytz/Manifest
@@ -1,2 +1,3 @@
DIST pytz-2016.3.tar.bz2 170906 BLAKE2B ae1c5336919cd60d643afcaec8889793092da1b16c6cf6ccab7816bb7169b5bd8abd9180e4571682fbc077e11786dbea14dcb6457291f5285cd9898ea84efccb SHA512 8d91a84500257327361a8ccd19ce2d2e5848c10c7d4105ec1be012be592ec38113611558c7894c1825cc1967303901fce35079fc799cc10e84216864cd00266f
DIST pytz-2017.2.zip 502168 BLAKE2B a1e02967700d0624d2c48bcedde52b772471aefcb1dc173fc067045a69d808dc8208ef300d67c683b0d49a0b19b6c22f9d5512a6a10559457e19a508e4b40ace SHA512 d67d64a64b4c21e0bd41da56020fc7b016aec9da7f3243f79b65704119f70b8a9cd4f5f905631b6761e06ecef93830e5e479e16c7b1611ac70e0cd2b39d5b916
+DIST pytz-2018.4.tar.gz 308066 BLAKE2B 665cebc5b535aafc92a1858b718d22818810534d8680a82ef3a0b66e6092f24226c36eb74feb690e25578b4d6ab8288cc4825eb5fb793345e11b0e71c6041868 SHA512 8a15e64d0d1a4b75c1e92360b22c06a41a692fe54fc8bfcff8cfa671095232d87f7929240441cd4d46826cd13f21d348125509c899be5a0b19bc7a77fdcb43c1
diff --git a/dev-python/pytz/files/2018.4-zoneinfo.patch b/dev-python/pytz/files/2018.4-zoneinfo.patch
new file mode 100644
index 000000000000..2eeeab416d7f
--- /dev/null
+++ b/dev-python/pytz/files/2018.4-zoneinfo.patch
@@ -0,0 +1,12 @@
+--- a/pytz/__init__.py
++++ b/pytz/__init__.py
+@@ -91,8 +91,7 @@
+ if zoneinfo_dir is not None:
+ filename = os.path.join(zoneinfo_dir, *name_parts)
+ else:
+- filename = os.path.join(os.path.dirname(__file__),
+- 'zoneinfo', *name_parts)
++ filename = os.path.join('/usr/share/zoneinfo', *name_parts)
+ if not os.path.exists(filename):
+ # http://bugs.launchpad.net/bugs/383171 - we avoid using this
+ # unless absolutely necessary to help when a broken version of
diff --git a/dev-python/pytz/files/pytz-2018.4-zoneinfo-noinstall.patch b/dev-python/pytz/files/pytz-2018.4-zoneinfo-noinstall.patch
new file mode 100644
index 000000000000..9f8b93bf70a5
--- /dev/null
+++ b/dev-python/pytz/files/pytz-2018.4-zoneinfo-noinstall.patch
@@ -0,0 +1,18 @@
+--- a/setup.py
++++ b/setup.py
+@@ -15,15 +15,8 @@
+ memail = 'stuart@stuartbishop.net'
+ packages = ['pytz']
+ resources = ['zone.tab', 'locales/pytz.pot']
+-for dirpath, dirnames, filenames in os.walk(os.path.join('pytz', 'zoneinfo')):
+- # remove the 'pytz' part of the path
+- basepath = dirpath.split(os.path.sep, 1)[1]
+- resources.extend([os.path.join(basepath, filename)
+- for filename in filenames])
+ package_data = {'pytz': resources}
+
+-assert len(resources) > 10, 'zoneinfo files not found!'
+-
+ setup(
+ name='pytz',
+ version=pytz.VERSION,
diff --git a/dev-python/pytz/pytz-2018.4.ebuild b/dev-python/pytz/pytz-2018.4.ebuild
new file mode 100644
index 000000000000..cbf731d3b20b
--- /dev/null
+++ b/dev-python/pytz/pytz-2018.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="http://pythonhosted.org/pytz/ https://pypi.org/project/pytz/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ || ( >=sys-libs/timezone-data-2017a sys-libs/glibc[vanilla] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}"/2018.4-zoneinfo.patch
+ # ...and do not install a copy of it.
+ "${FILESDIR}"/${PN}-2018.4-zoneinfo-noinstall.patch
+)
+
+python_test() {
+ "${PYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
+}