summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pywavelets/pywavelets-0.4.0.ebuild')
-rw-r--r--dev-python/pywavelets/pywavelets-0.4.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pywavelets/pywavelets-0.4.0.ebuild b/dev-python/pywavelets/pywavelets-0.4.0.ebuild
new file mode 100644
index 000000000000..387ad4a82ab4
--- /dev/null
+++ b/dev-python/pywavelets/pywavelets-0.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+RESTRICT="test"
+
+MY_PN="${PN/pyw/PyW}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python module for discrete, stationary, and packet wavelet transforms"
+HOMEPAGE="http://www.pybytes.com/pywavelets https://github.com/PyWavelets/pywt"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+DEPEND="
+ app-arch/unzip
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ # Taken form tox.ini
+ "${PYTHON}" runtests.py -n -m full pywt/tests/ || die
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use examples && local EXAMPLES=( demo/. )
+
+ distutils-r1_python_install_all
+}