summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qdarkstyle')
-rw-r--r--dev-python/qdarkstyle/Manifest1
-rw-r--r--dev-python/qdarkstyle/qdarkstyle-3.2.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/qdarkstyle/Manifest b/dev-python/qdarkstyle/Manifest
index fa178b914c14..0bdfa14f4f23 100644
--- a/dev-python/qdarkstyle/Manifest
+++ b/dev-python/qdarkstyle/Manifest
@@ -1,2 +1,3 @@
DIST QDarkStyle-3.1.tar.gz 698602 BLAKE2B 8c96b2dd5532c9db0c1d813fe0cf049b7cf55ef6469d2ebb21b5ea85fe6ecd23e8a247c45f45cfa674f8012a4a03ea377df8cb7efac8f13c079e2512091ecdc7 SHA512 275fe333bcf2502f8f1ef61eca3f82d8909e760e8f88a1605157c5043cb1e4cad97bbb8ddb0464ef2125c1b70f318bfa8f0106d2721d6b9862c162b5f716aa4b
DIST QDarkStyle-3.2.1.tar.gz 681590 BLAKE2B 837b56ca96be3a03cc94840c7b70df3c6ef98d9edb7ec2d590dc82a06eef93c7d436746284e6d80e0d87212184ed67725bd40a87242ffae87f2afcaf311bb96e SHA512 435c836c9f5d61345cd9b37c151a990d1abb8c79505820cfb62ed4134f43511825a44709364bd8044e0f3acc9d63e1ccf65984334165707f9b28739f6745df50
+DIST QDarkStyle-3.2.2.tar.gz 698131 BLAKE2B 98fa7684fb97c1a719b73f893b0d32fcbfb6453f62847bf40a3f92794b1f24c5396c988cff0aa3cbe877615c9762522c911afb15b1765335d9c1ff34a3217d91 SHA512 e0f428565280b453af49f12f2c3298fe1d5d78358acfe350d6cbb4d5780a851ab4d10016d2a5836292218e4d114d0c021ac67d0a3b1b62441c32b779275e66b7
diff --git a/dev-python/qdarkstyle/qdarkstyle-3.2.2.ebuild b/dev-python/qdarkstyle/qdarkstyle-3.2.2.ebuild
new file mode 100644
index 000000000000..c83697e8bea2
--- /dev/null
+++ b/dev-python/qdarkstyle/qdarkstyle-3.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="QDarkStyle"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A dark style sheet for QtWidgets application"
+HOMEPAGE="
+ https://github.com/ColinDuquesnoy/QDarkStyleSheet/
+ https://pypi.org/project/QDarkStyle/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/QtPy-2.0.0[gui,${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/qtsass[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.0.0[gui,testlib,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "Retrieve detailed system information and report bugs upstream" dev-python/helpdev
+ optfeature "qdarkstyle.utils" dev-python/qtsass dev-python/watchdog
+}