summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qiskit-terra/qiskit-terra-0.24.1.ebuild')
-rw-r--r--dev-python/qiskit-terra/qiskit-terra-0.24.1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/qiskit-terra/qiskit-terra-0.24.1.ebuild b/dev-python/qiskit-terra/qiskit-terra-0.24.1.ebuild
index 21c1d9652825..9349a3d16269 100644
--- a/dev-python/qiskit-terra/qiskit-terra-0.24.1.ebuild
+++ b/dev-python/qiskit-terra/qiskit-terra-0.24.1.ebuild
@@ -189,10 +189,11 @@ python_test() {
)
rm -rf qiskit || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# Run the Python test suite rather than everything under test/ which
# includes the 'randomized' suite. Upstream run that in a separate CI job.
# Note: use -p timeout --timeout 500 if debugging hanging tests.
- epytest -p xdist -n "$(makeopts_jobs)" test/python
+ epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal test/python
}
pkg_postinst() {