summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/raet')
-rw-r--r--dev-python/raet/files/raet-0.6.8-py310.patch69
-rw-r--r--dev-python/raet/raet-0.6.8-r3.ebuild40
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/raet/files/raet-0.6.8-py310.patch b/dev-python/raet/files/raet-0.6.8-py310.patch
new file mode 100644
index 000000000000..94e5287db0b6
--- /dev/null
+++ b/dev-python/raet/files/raet-0.6.8-py310.patch
@@ -0,0 +1,69 @@
+diff --git a/raet/lane/paging.py b/raet/lane/paging.py
+index 5a2f480..e33d95c 100644
+--- a/raet/lane/paging.py
++++ b/raet/lane/paging.py
+@@ -6,7 +6,7 @@ paging module provides classes for RAET UXD messaging management
+ '''
+
+ # Import python libs
+-from collections import Mapping
++from collections.abc import Mapping
+ try:
+ import simplejson as json
+ except ImportError:
+diff --git a/raet/lane/stacking.py b/raet/lane/stacking.py
+index 3969cd9..be88111 100644
+--- a/raet/lane/stacking.py
++++ b/raet/lane/stacking.py
+@@ -11,7 +11,8 @@ import sys
+ import os
+ import errno
+
+-from collections import deque, Mapping
++from collections import deque
++from collections.abc import Mapping
+ try:
+ import simplejson as json
+ except ImportError:
+diff --git a/raet/road/packeting.py b/raet/road/packeting.py
+index 0675912..078d76d 100644
+--- a/raet/road/packeting.py
++++ b/raet/road/packeting.py
+@@ -6,7 +6,8 @@ packeting module provides classes for Raet packets
+ '''
+
+ # Import python libs
+-from collections import Mapping, deque
++from collections import deque
++from collections.abc import Mapping
+ try:
+ import simplejson as json
+ except ImportError:
+diff --git a/raet/road/stacking.py b/raet/road/stacking.py
+index 924ae52..4d8670b 100644
+--- a/raet/road/stacking.py
++++ b/raet/road/stacking.py
+@@ -10,7 +10,8 @@ import socket
+ import os
+ import errno
+
+-from collections import deque, Mapping
++from collections import deque
++from collections.abc import Mapping
+ try:
+ import simplejson as json
+ except ImportError:
+diff --git a/raet/stacking.py b/raet/stacking.py
+index 0a1743a..9244b66 100644
+--- a/raet/stacking.py
++++ b/raet/stacking.py
+@@ -13,7 +13,8 @@ import sys
+ if sys.version_info > (3,):
+ long = int
+
+-from collections import deque, Mapping
++from collections import deque
++from collections.abc import Mapping
+ try:
+ import simplejson as json
+ except ImportError:
diff --git a/dev-python/raet/raet-0.6.8-r3.ebuild b/dev-python/raet/raet-0.6.8-r3.ebuild
new file mode 100644
index 000000000000..a35e26f13bd5
--- /dev/null
+++ b/dev-python/raet/raet-0.6.8-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{7..10})
+inherit distutils-r1
+
+DESCRIPTION="Reliable Asynchronous Event Transport Protocol"
+HOMEPAGE="https://github.com/RaetProtocol/raet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/libnacl-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/ioflo-2.0[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/raet-0.6.8-msgpack-1.0.patch"
+ "${FILESDIR}/raet-0.6.8-py310.patch"
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "/setuptools_git/d" -i setup.py || die
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib || die
+ ${EPYTHON} ${PN}/test/__init__.py || die "tests failed for ${EPYTHON}"
+ popd || die
+}