summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rapidfuzz-capi/rapidfuzz-capi-1.0.5.ebuild')
-rw-r--r--dev-python/rapidfuzz-capi/rapidfuzz-capi-1.0.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/rapidfuzz-capi/rapidfuzz-capi-1.0.5.ebuild b/dev-python/rapidfuzz-capi/rapidfuzz-capi-1.0.5.ebuild
new file mode 100644
index 000000000000..25a7cc31b8c8
--- /dev/null
+++ b/dev-python/rapidfuzz-capi/rapidfuzz-capi-1.0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=rapidfuzz_capi-${PV}
+DESCRIPTION="C-API of RapidFuzz, which can be used to extend RapidFuzz"
+HOMEPAGE="
+ https://github.com/maxbachmann/rapidfuzz_capi/
+ https://pypi.org/project/rapidfuzz-capi/
+"
+SRC_URI="
+ https://github.com/maxbachmann/rapidfuzz_capi/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"