summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rebulk/rebulk-0.7.2.ebuild')
-rw-r--r--dev-python/rebulk/rebulk-0.7.2.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/rebulk/rebulk-0.7.2.ebuild b/dev-python/rebulk/rebulk-0.7.2.ebuild
deleted file mode 100644
index 7f3aee954b53..000000000000
--- a/dev-python/rebulk/rebulk-0.7.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library that performs advanced searches in strings"
-HOMEPAGE="https://github.com/Toilal/rebulk https://pypi.python.org/pypi/rebulk"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Remove base64-encoded zip archive with pytest.
- rm runtests.py || die
-
- # Disable unconditional dependency on dev-python/pytest-runner.
- sed -i -e "s|'pytest-runner'||g" setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}