summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rebulk')
-rw-r--r--dev-python/rebulk/Manifest1
-rw-r--r--dev-python/rebulk/rebulk-3.0.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/rebulk/Manifest b/dev-python/rebulk/Manifest
index 6af83f502536..9feac58b6a6b 100644
--- a/dev-python/rebulk/Manifest
+++ b/dev-python/rebulk/Manifest
@@ -1 +1,2 @@
DIST rebulk-2.0.1.tar.gz 258115 BLAKE2B d19210911cf89cb7c371819e384da95c2159eb92abf9f027cbdf1803a18054c556e73364ae10c5bb0b5007cbdb2156b2118d22d6e278b6a02055bacbcbdbc322 SHA512 7d453b7ba952994dec3258aa95a3f6090e6f8afb5a674c1b5e54e036f41022b887d3d65d21f2023ae6e2596cce3baf52d33fc23708498a4f0aef26d3594c8289
+DIST rebulk-3.0.0.gh.tar.gz 252364 BLAKE2B 669f25fa4cf25d4de426552eafd1f3463c05e42eb6f587b8c15d0d319c9c81e515d8461c5c412bd89a483d619374af0a93849deb0ccb3af9ccd7617ebd908504 SHA512 eb474b8b8509f291938bc3c96ef591b8233a41b9eb28f7957f3d20e098140ac6d80a1337c6ff1c89eeea4c34f94eb37af811d2200a8f2a574fc93b8fa1ea3c5d
diff --git a/dev-python/rebulk/rebulk-3.0.0.ebuild b/dev-python/rebulk/rebulk-3.0.0.ebuild
new file mode 100644
index 000000000000..35dcb15832cc
--- /dev/null
+++ b/dev-python/rebulk/rebulk-3.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library that performs advanced searches in strings"
+HOMEPAGE="https://github.com/Toilal/rebulk https://pypi.org/project/rebulk/"
+SRC_URI="
+ https://github.com/Toilal/rebulk/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove base64-encoded zip archive with pytest.
+ rm runtests.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}