summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/regex/regex-2021.8.3.ebuild')
-rw-r--r--dev-python/regex/regex-2021.8.3.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/regex/regex-2021.8.3.ebuild b/dev-python/regex/regex-2021.8.3.ebuild
deleted file mode 100644
index 4a336d826c82..000000000000
--- a/dev-python/regex/regex-2021.8.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Alternative regular expression module to replace re"
-HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="doc"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2021.4.4-pypy3-fix-test_empty_array.patch"
- "${FILESDIR}/${PN}-2021.4.4-pypy3-fix-test_issue_18468.patch"
-)
-
-distutils_enable_tests unittest
-
-python_test() {
- eunittest -s "${BUILD_DIR}"/lib
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/Features.html )
- local DOCS=( README.rst docs/*.rst )
-
- distutils-r1_python_install_all
-}