summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/regions/regions-0.2.ebuild')
-rw-r--r--dev-python/regions/regions-0.2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/regions/regions-0.2.ebuild b/dev-python/regions/regions-0.2.ebuild
new file mode 100644
index 000000000000..33f3297e1291
--- /dev/null
+++ b/dev-python/regions/regions-0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Astropy affiliated package for region handling"
+HOMEPAGE="http://astropy-regions.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD"
+
+IUSE="doc test"
+RDEPEND="dev-python/astropy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ dev-python/wcsaxes[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest-mpl[${PYTHON_USEDEP}]
+ dev-python/pytest-arraydiff[${PYTHON_USEDEP}]
+ dev-python/wcsaxes[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # use astropy-helpers from system
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ echo 'backend: Agg' > ${WORKDIR}/matplotlibrc || die
+ export MATPLOTLIBRC=${WORKDIR}
+ virtx esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}