summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/resolvelib')
-rw-r--r--dev-python/resolvelib/Manifest3
-rw-r--r--dev-python/resolvelib/metadata.xml10
-rw-r--r--dev-python/resolvelib/resolvelib-0.5.4.ebuild20
-rw-r--r--dev-python/resolvelib/resolvelib-0.7.1.ebuild25
-rw-r--r--dev-python/resolvelib/resolvelib-1.0.1.ebuild33
5 files changed, 39 insertions, 52 deletions
diff --git a/dev-python/resolvelib/Manifest b/dev-python/resolvelib/Manifest
index abe167476e97..32d6b9d48345 100644
--- a/dev-python/resolvelib/Manifest
+++ b/dev-python/resolvelib/Manifest
@@ -1,2 +1 @@
-DIST resolvelib-0.5.4.tar.gz 14474 BLAKE2B d1424bf6a019e16e9b662741b6c089258bfef26d5bffcfc9e0c8d9ba105b689654fdce7bf9068f71c49a2ce590f05c16b93c53bbe468fc1a339e7fa489adece2 SHA512 cb027c5478c217f6f8288b42a933665aaf6e59280e7aa88a25f6594e589e34ac2b75734764e331d0889ad9cf0c60b8cbdfa14b01dce023a76870bb21cfc4d926
-DIST resolvelib-0.7.1.gh.tar.gz 764630 BLAKE2B 32c50ef0a16e07716f18994efe4b2bd212a2ee5068ff155526e17358e3bbe4c92c4d59817c17de152882a738c924c7f5ba389d2a7d13ee1b2dc0de54e8175c3b SHA512 de5c1c29790ce1eb4393021f17f1a19a0f2de29e5d8688fc307e412d80052319b822bb24fceca47fe550e21393ee38d58fa6e6cfefd207b7a88b632b9670d282
+DIST resolvelib-1.0.1.gh.tar.gz 769608 BLAKE2B 7715f61d262cb79ce08f0431650e6213def4582a0774cf36dab722d88013f7bc9c72a31a957d3782e35b315158982c3311fe3e06e26bbf9040fa96b239934661 SHA512 a35f7fdbc3aba5b44fdf6b9c55b082156ca641dfe5825611be6364622bcaaf45faafa2c45bdd13d1b5723a55732759a806905ab4b6f366fba0474d1f808d91bc
diff --git a/dev-python/resolvelib/metadata.xml b/dev-python/resolvelib/metadata.xml
index 1363c414cd95..626ec9a67cd1 100644
--- a/dev-python/resolvelib/metadata.xml
+++ b/dev-python/resolvelib/metadata.xml
@@ -15,9 +15,9 @@
<bugs-to>https://github.com/sarugaku/resolvelib/issues</bugs-to>
</upstream>
<longdescription lang="en">
-ResolveLib at the highest level provides a Resolver class that includes
-dependency resolution logic. You give it some things, and a little
-information on how it should interact with them, and it will spit out
-a resolution result.
-</longdescription>
+ ResolveLib at the highest level provides a Resolver class that includes
+ dependency resolution logic. You give it some things, and a little
+ information on how it should interact with them, and it will spit out
+ a resolution result.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-python/resolvelib/resolvelib-0.5.4.ebuild b/dev-python/resolvelib/resolvelib-0.5.4.ebuild
deleted file mode 100644
index 073d81b1a57b..000000000000
--- a/dev-python/resolvelib/resolvelib-0.5.4.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-inherit distutils-r1
-
-DESCRIPTION="provides a Resolver class that includes dependency resolution logic"
-HOMEPAGE="https://github.com/sarugaku/resolvelib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-BDEPEND=""
diff --git a/dev-python/resolvelib/resolvelib-0.7.1.ebuild b/dev-python/resolvelib/resolvelib-0.7.1.ebuild
deleted file mode 100644
index 5d0796ab827c..000000000000
--- a/dev-python/resolvelib/resolvelib-0.7.1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="provides a Resolver class that includes dependency resolution logic"
-HOMEPAGE="https://github.com/sarugaku/resolvelib/"
-SRC_URI="
- https://github.com/sarugaku/resolvelib/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-
-BDEPEND="
- test? (
- dev-python/commentjson[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
diff --git a/dev-python/resolvelib/resolvelib-1.0.1.ebuild b/dev-python/resolvelib/resolvelib-1.0.1.ebuild
new file mode 100644
index 000000000000..091e5388976b
--- /dev/null
+++ b/dev-python/resolvelib/resolvelib-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Resolve abstract dependencies into concrete ones"
+HOMEPAGE="
+ https://github.com/sarugaku/resolvelib/
+ https://pypi.org/project/resolvelib/
+
+"
+SRC_URI="
+ https://github.com/sarugaku/resolvelib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
+
+BDEPEND="
+ test? (
+ dev-python/commentjson[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest