summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/responses/responses-0.22.0-r1.ebuild')
-rw-r--r--dev-python/responses/responses-0.22.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/responses/responses-0.22.0-r1.ebuild b/dev-python/responses/responses-0.22.0-r1.ebuild
new file mode 100644
index 000000000000..7c1c6e391766
--- /dev/null
+++ b/dev-python/responses/responses-0.22.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility for mocking out the Python Requests library"
+HOMEPAGE="
+ https://pypi.org/project/responses/
+ https://github.com/getsentry/responses/
+"
+SRC_URI="
+ https://github.com/getsentry/responses/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/getsentry/responses/pull/596.patch
+ -> ${P}-tomli.patch
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.10[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${DISTDIR}"/${P}-tomli.patch
+)