summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/restructuredtext-lint/restructuredtext-lint-1.4.0.ebuild')
-rw-r--r--dev-python/restructuredtext-lint/restructuredtext-lint-1.4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/restructuredtext-lint/restructuredtext-lint-1.4.0.ebuild b/dev-python/restructuredtext-lint/restructuredtext-lint-1.4.0.ebuild
new file mode 100644
index 000000000000..aad0a640e8a9
--- /dev/null
+++ b/dev-python/restructuredtext-lint/restructuredtext-lint-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="${P/-/_}"
+DESCRIPTION="Checks PyPI validity of reStructuredText"
+HOMEPAGE="https://pypi.org/project/restructuredtext_lint/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+ <dev-python/docutils-1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest