summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rosdistro')
-rw-r--r--dev-python/rosdistro/Manifest1
-rw-r--r--dev-python/rosdistro/rosdistro-0.6.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/rosdistro/Manifest b/dev-python/rosdistro/Manifest
index 167abc6bbfcf..aaae1418e690 100644
--- a/dev-python/rosdistro/Manifest
+++ b/dev-python/rosdistro/Manifest
@@ -1 +1,2 @@
DIST rosdistro-0.6.1.tar.gz 48699 SHA256 51c9a3a5ff4931310c6c7cf5a23a2c64b2432ed9154a159a9ca3ce55c608600f SHA512 9f7c9eea737da443b1daaacde6bcea163ac2ffc707efb23016fe77c68423ee192e0610b9aa1c8a4b07735d1784e30a509dc78cf256061fcc4de75ed4c4244f75 WHIRLPOOL 3dca25a0cd68efa41e21d71d1528213f9ca54719ea3b1dc3cb8e90b6a932d98d97874d4cf6ef3630f3413a7a15b6004bbba8e3aa72d509d11836d3a6cee79519
+DIST rosdistro-0.6.2.tar.gz 42658 SHA256 834776e7419465b23080b099ddb3b981fbe8623442ed2b446989f3fa998fb178 SHA512 df7da98a2b46d45d978bbb371ea98cf24aafa0704c1cd991db0f1b785eb3330227d42a505b765653bf11d267f676844e1043e5fcff52b7295afa1b21ffc99301 WHIRLPOOL 1e72ee793fef552e8b674e11a90d8a981a63cb109fca499d59c3e75353ffb472777e369b48cabb606d1d863e9e9d591352ac3d5d020b77c750dbbbe68840a95d
diff --git a/dev-python/rosdistro/rosdistro-0.6.2.ebuild b/dev-python/rosdistro/rosdistro-0.6.2.ebuild
new file mode 100644
index 000000000000..e9ccf8b2beb3
--- /dev/null
+++ b/dev-python/rosdistro/rosdistro-0.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-xunit test || die
+}