summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rpds-py/rpds-py-0.13.0.ebuild')
-rw-r--r--dev-python/rpds-py/rpds-py-0.13.0.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/rpds-py/rpds-py-0.13.0.ebuild b/dev-python/rpds-py/rpds-py-0.13.0.ebuild
deleted file mode 100644
index 7f129d9ada99..000000000000
--- a/dev-python/rpds-py/rpds-py-0.13.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=maturin
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-CRATES="
- archery@1.1.0
- autocfg@1.1.0
- bitflags@1.3.2
- cfg-if@1.0.0
- heck@0.4.1
- indoc@2.0.4
- libc@0.2.147
- lock_api@0.4.10
- memoffset@0.9.0
- once_cell@1.18.0
- parking_lot@0.12.1
- parking_lot_core@0.9.8
- proc-macro2@1.0.66
- pyo3-build-config@0.20.0
- pyo3-ffi@0.20.0
- pyo3-macros-backend@0.20.0
- pyo3-macros@0.20.0
- pyo3@0.20.0
- quote@1.0.31
- redox_syscall@0.3.5
- rpds@1.1.0
- scopeguard@1.1.0
- smallvec@1.11.0
- static_assertions@1.1.0
- syn@2.0.32
- target-lexicon@0.12.9
- triomphe@0.1.9
- unicode-ident@1.0.11
- unindent@0.2.3
- windows-targets@0.48.1
- windows_aarch64_gnullvm@0.48.0
- windows_aarch64_msvc@0.48.0
- windows_i686_gnu@0.48.0
- windows_i686_msvc@0.48.0
- windows_x86_64_gnu@0.48.0
- windows_x86_64_gnullvm@0.48.0
- windows_x86_64_msvc@0.48.0
-"
-
-inherit cargo distutils-r1 pypi
-
-DESCRIPTION="Python bindings to Rust's persistent data structures (rpds)"
-HOMEPAGE="
- https://github.com/crate-py/rpds/
- https://pypi.org/project/rpds-py/
-"
-SRC_URI+="
- ${CARGO_CRATE_URIS}
-"
-
-LICENSE="MIT"
-# Dependent crate licenses
-LICENSE+=" Apache-2.0-with-LLVM-exceptions MIT MPL-2.0 Unicode-DFS-2016"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/rpds/rpds.*.so"
-
-distutils_enable_tests pytest