summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rpy/rpy-2.8.6.ebuild')
-rw-r--r--dev-python/rpy/rpy-2.8.6.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/rpy/rpy-2.8.6.ebuild b/dev-python/rpy/rpy-2.8.6.ebuild
deleted file mode 100644
index 860a83e5bc0e..000000000000
--- a/dev-python/rpy/rpy-2.8.6.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 flag-o-matic virtualx
-
-MYSLOT=2
-MY_PN=${PN}${MYSLOT}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the R Programming Language"
-HOMEPAGE="http://rpy2.bitbucket.io/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# ggplot2 is a test dep but not in portage
-RESTRICT="test"
-
-RDEPEND="
- >=dev-lang/R-3.2
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( >=dev-lang/R-3.2[X,png] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- virtx "${EPYTHON}" -m 'rpy2.tests' || die
-}