summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rpy/rpy-3.5.4.ebuild')
-rw-r--r--dev-python/rpy/rpy-3.5.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/rpy/rpy-3.5.4.ebuild b/dev-python/rpy/rpy-3.5.4.ebuild
new file mode 100644
index 000000000000..33ae4762eb31
--- /dev/null
+++ b/dev-python/rpy/rpy-3.5.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 virtualx
+
+MYSLOT=2
+MY_PN=${PN}${MYSLOT}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the R Programming Language"
+HOMEPAGE="https://rpy.sourceforge.net/
+ https://pypi.org/project/rpy2/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# ggplot2 is a test dep but not in portage
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/R-3.2
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+"
+PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ virtx "${EPYTHON}" -m 'rpy2.tests'
+}