summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild')
-rw-r--r--dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild b/dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild
new file mode 100644
index 000000000000..b593b7430083
--- /dev/null
+++ b/dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="RTIMULib"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Binding for RTIMULib, a versatile IMU library"
+HOMEPAGE="https://github.com/RPi-Distro/RTIMULib"
+SRC_URI="https://github.com/RPi-Distro/${MY_PN}/archive/V${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/Linux/python"