summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ruamel-yaml/ruamel-yaml-0.16.13-r1.ebuild')
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.16.13-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.16.13-r1.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.16.13-r1.ebuild
new file mode 100644
index 000000000000..e9ee0a56b9bf
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.16.13-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="https://pypi.org/project/ruamel.yaml/ https://sourceforge.net/p/ruamel-yaml"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# Running the test suite is broken for now, WIP
+RESTRICT="test"
+
+RDEPEND="dev-python/namespace-ruamel[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+)"
+
+S="${WORKDIR}"/${MY_P}
+
+distutils_enable_tests pytest
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}