summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest5
-rw-r--r--dev-python/ruamel-yaml/metadata.xml4
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.10.ebuild50
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.15.ebuild47
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.16.ebuild47
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild53
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.18.6.ebuild53
7 files changed, 108 insertions, 151 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index 457d7cb07428..2c57b89997d9 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1,3 +1,2 @@
-DIST ruamel-yaml-0.17.10.tar.xz 183116 BLAKE2B 2795f470a3f7da609780109dfac502a5b47184f465c68420f467209275c8857418a4ec7424e130df2e7acef614d93f91551910eceb06cd9e49b365bb23d2a015 SHA512 3cd2598fa37564c44c74720e72babcd2252b2dbcdde626bdcf771b591da5d2852d90bb1f22428e28cd7ec38304be2a437aa0569ffbd3ebb526b2b79a955bc88d
-DIST ruamel.yaml-0.17.15.tar.xz 183820 BLAKE2B 901c08d05994a45cb9d8e7071244332c7b3f30fb83f22f9f2f9cfb769ec99ebc39fbdbcf652bc8e7ae8e5b9918aafbc229bcfcbeb1b7d64bd4bed2f8fe0d9ee7 SHA512 cd2fd4d0e2aba1f3f90bd54b355fa603045e913f90c7e460bcc4630619db027b1283af77c613fdc029f48300d8822ca349fb169e30679a1dd86beb1a3f75c49f
-DIST ruamel.yaml-0.17.16.tar.xz 183884 BLAKE2B 3f7b0995cfa49ed9e19b5dafbddc7514f58ab23186410b4a718027112be471d9136675259800e0136b21ad6d1645c364f14ac071dc10d12a5f60aefdc05bc56f SHA512 7da1e5c229b78ecdccd648fb6a734095c0a1e0848eaf46af93e6ce69f5e065cdd07eb65217f8b3e4c82ce383dc11de07a1345026c6782aa26c4ad0f5a85fd80f
+DIST ruamel.yaml-0.17.40.tar.xz 193424 BLAKE2B 80405ef0c85af476ef0e996b1da5aba1a116e8c181d18f40fb4fd86093a512c09cf0da30d52d85946c524e86e10379cb11154cb08a7ea7b054ba9379996de4f4 SHA512 848af49430b9c028a6676a159915c66e29f4290374ba0863e4fd87527f3178bb303a80f4ba97139fc8cbcd01f7f7782a4b3112325237a39659e227afda61fcb8
+DIST ruamel.yaml-0.18.6.tar.xz 198544 BLAKE2B 94d50ba8aef92e2885b24118bd9f4b1d06a82d51b2e7930c39dea93f4c0f9fc9d0604dfbbe716f81f3c9a927698d14c7005bb0ce2ae5d2eadf27514dfbba88c1 SHA512 319e1029746ebf6ef1c6b6bf6055d7c56e7caa2559b34b4fe639616c4332ef46661afad67c42d123bd0de67819812ea8f9cc9d51c0189edd6e33d5d47f47bb26
diff --git a/dev-python/ruamel-yaml/metadata.xml b/dev-python/ruamel-yaml/metadata.xml
index 5214b2a0fc07..005ccc63c8de 100644
--- a/dev-python/ruamel-yaml/metadata.xml
+++ b/dev-python/ruamel-yaml/metadata.xml
@@ -2,10 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>andrey_utkin@gentoo.org</email>
- <name>Andrey Utkin</name>
- </maintainer>
- <maintainer type="person">
<email>marecki@gentoo.org</email>
<name>Marek Szuba</name>
</maintainer>
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.10.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.10.ebuild
deleted file mode 100644
index 86fa6a9be480..000000000000
--- a/dev-python/ruamel-yaml/ruamel-yaml-0.17.10.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-
-inherit distutils-r1
-
-MY_PN="${PN//-/.}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
-HOMEPAGE="
- https://pypi.org/project/ruamel.yaml/
- https://sourceforge.net/p/ruamel-yaml/"
-# PyPI tarballs do not include tests
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz -> ${P}.tar.xz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- dev-python/namespace-ruamel[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
-# via test_z_olddata, tell pytest itself to leave the subdir alone.
-python_test() {
- local deselect=()
-
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- _test/test_deprecation.py::test_collections_deprecation
- )
-
- epytest --ignore _test/lib/ ${deselect[@]/#/--deselect }
-}
-
-python_install() {
- distutils-r1_python_install --single-version-externally-managed
- find "${ED}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.15.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.15.ebuild
deleted file mode 100644
index f87789872e5e..000000000000
--- a/dev-python/ruamel-yaml/ruamel-yaml-0.17.15.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-MY_P="${P/-/.}"
-DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
-HOMEPAGE="
- https://pypi.org/project/ruamel.yaml/
- https://sourceforge.net/p/ruamel-yaml/"
-# PyPI tarballs do not include tests
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- dev-python/namespace-ruamel[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
-# via test_z_olddata, tell pytest itself to leave the subdir alone.
-python_test() {
- local deselect=()
-
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- _test/test_deprecation.py::test_collections_deprecation
- )
-
- epytest --ignore _test/lib/ ${deselect[@]/#/--deselect }
-}
-
-python_install() {
- distutils-r1_python_install --single-version-externally-managed
- find "${ED}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.16.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.16.ebuild
deleted file mode 100644
index f87789872e5e..000000000000
--- a/dev-python/ruamel-yaml/ruamel-yaml-0.17.16.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-MY_P="${P/-/.}"
-DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
-HOMEPAGE="
- https://pypi.org/project/ruamel.yaml/
- https://sourceforge.net/p/ruamel-yaml/"
-# PyPI tarballs do not include tests
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- dev-python/namespace-ruamel[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
-# via test_z_olddata, tell pytest itself to leave the subdir alone.
-python_test() {
- local deselect=()
-
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- _test/test_deprecation.py::test_collections_deprecation
- )
-
- epytest --ignore _test/lib/ ${deselect[@]/#/--deselect }
-}
-
-python_install() {
- distutils-r1_python_install --single-version-externally-managed
- find "${ED}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild
new file mode 100644
index 000000000000..0b0839c508c1
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="https://downloads.sourceforge.net/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+ !dev-python/namespace-ruamel
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ distutils_write_namespace ruamel
+ epytest
+}
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.18.6.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.18.6.ebuild
new file mode 100644
index 000000000000..6c7d0b943af2
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.18.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="https://downloads.sourceforge.net/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+ !dev-python/namespace-ruamel
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ distutils_write_namespace ruamel
+ epytest
+}