summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/schema/schema-0.7.5-r1.ebuild')
-rw-r--r--dev-python/schema/schema-0.7.5-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/schema/schema-0.7.5-r1.ebuild b/dev-python/schema/schema-0.7.5-r1.ebuild
new file mode 100644
index 000000000000..8c9f00ff5075
--- /dev/null
+++ b/dev-python/schema/schema-0.7.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple data validation library"
+HOMEPAGE="
+ https://github.com/keleshev/schema/
+ https://pypi.org/project/schema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # py2 leftover
+ > requirements.txt || die
+ distutils-r1_src_prepare
+}