summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/semantic_version/semantic_version-2.8.5.ebuild')
-rw-r--r--dev-python/semantic_version/semantic_version-2.8.5.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/semantic_version/semantic_version-2.8.5.ebuild b/dev-python/semantic_version/semantic_version-2.8.5.ebuild
new file mode 100644
index 000000000000..cad82361d1cd
--- /dev/null
+++ b/dev-python/semantic_version/semantic_version-2.8.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python library providing a few tools handling SemVer in Python"
+HOMEPAGE="https://pypi.org/project/semantic_version/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+#SRC_URI="https://github.com/rbarrois/python-semanticversion/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest