summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/setuptools/setuptools-7.0.ebuild')
-rw-r--r--dev-python/setuptools/setuptools-7.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/setuptools/setuptools-7.0.ebuild b/dev-python/setuptools/setuptools-7.0.ebuild
deleted file mode 100644
index bf32c87ded0f..000000000000
--- a/dev-python/setuptools/setuptools-7.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="a collection of extensions to Distutils"
-HOMEPAGE="https://pypi.python.org/pypi/setuptools"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-# Force in-source build because build system modifies sources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
-
-python_prepare_all() {
- # Disable tests requiring network connection.
- rm -f setuptools/tests/test_packageindex.py
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
- # It tries to sandbox the test in a tempdir
- HOME="${PWD}" esetup.py test
-}
-
-python_install() {
- export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
- distutils-r1_python_install
-}