summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild')
-rw-r--r--dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
new file mode 100644
index 000000000000..0747a0892490
--- /dev/null
+++ b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A setuptools_scm plugin for git archives"
+HOMEPAGE="https://github.com/Changaco/setuptools_scm_git_archive"
+SRC_URI="https://github.com/Changaco/setuptools_scm_git_archive/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test
+}