summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simple-websocket/simple-websocket-1.0.0.ebuild')
-rw-r--r--dev-python/simple-websocket/simple-websocket-1.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/simple-websocket/simple-websocket-1.0.0.ebuild b/dev-python/simple-websocket/simple-websocket-1.0.0.ebuild
new file mode 100644
index 000000000000..c286f8890d50
--- /dev/null
+++ b/dev-python/simple-websocket/simple-websocket-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple WebSocket server and client for Python"
+HOMEPAGE="
+ https://github.com/miguelgrinberg/simple-websocket/
+ https://pypi.org/project/simple-websocket/
+"
+# upstream refuses to provide working tests in sdist
+# https://github.com/miguelgrinberg/simple-websocket/issues/31
+SRC_URI="
+ https://github.com/miguelgrinberg/simple-websocket/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/wsproto[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest