summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/six/six-1.16.0-r1.ebuild')
-rw-r--r--dev-python/six/six-1.16.0-r1.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/dev-python/six/six-1.16.0-r1.ebuild b/dev-python/six/six-1.16.0-r1.ebuild
index df1788703008..9850b41681e3 100644
--- a/dev-python/six/six-1.16.0-r1.ebuild
+++ b/dev-python/six/six-1.16.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -23,9 +23,19 @@ distutils_enable_tests pytest
python_test() {
local EPYTEST_DESELECT=()
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- 'test_six.py::test_move_items[dbm_ndbm]'
- )
-
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ 'test_six.py::test_move_items[dbm_ndbm]'
+ )
+ ;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ 'test_six.py::test_move_items[tkinter_tix]'
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}